vendredi 10 août 2018

GIMP 2.10.4 Portable 32 bits et 64 bits Win Version 4 (Compilation gimp.org)

Voici une version mise à jour de Gimp 2.10.4 Portable 32 bits et 64 bits pour Windows.

Elle corrige le problème Twain 32 de hiérarchie d'accès aux DLL et elle est basée sur la compilation de Gimp 2.10.4-2 faite par Jernej Simončič disponible sur https://download.gimp.org/pub/gimp/v2.10/windows/ , un gros merci à lui :o)

Si votre version Gimp-2.10.4_Portable-32bit-64bit-V3 fonctionne il ne sera pas nécessaire de télécharger cette mise à jour.

Merci aux développeurs pour tous leurs efforts  :o)

Cette version contient G'MIC-QT-GIMP (32 et 64 bits).

Pour l'installation de cette version portable il suffit de décompresser l'archive dans la racine d'un disque dur ou d'une clef USB.
Pour décompresser rapidement cette archive utilisez 7-Zip : http://www.7-zip.org/
Il faut éviter de décompresser dans un répertoire dont le nom contient des caractères accentués ou des espaces.

Cette version portable est expérimentale.
Python 64 bits est installé.

Lancement de Gimp en 64 bits
Lancement en plusieurs langues via un des 7 fichiers .exe du répertoire
\Gimp-2.10.4_Portable-32bit-64bit-V4 , par exemple GIMP_EN.exe

Lancement de Gimp en 32 bits
Lancement en plusieurs langues via un des 7 fichiers .exe du répertoire
\Gimp-2.10.4_Portable-32bit-64bit-V4\32 , par exemple GIMP_EN.exe

Le premier lancement de Gimp est lent...

Valider l’option 'Utiliser OpenCL' dans les Préférences pour augmenter la rapidité des filtres par :
Édition > Préférences

Important

- NE PAS ESSAYER DE MÉLANGER LES DLL, DE LES ÉCRASER.

Téléchargements

à partir de cet hébergement gratuit valable pendant environ 1 mois


ou 



Volume : 206 Mo (216 030 959 octets)
MD5 : ea231566f8663a4767d9dab67d6149bf
Volume décompressé ~ 1.05 Go


*****

Les sources de Gimp sont disponibles sur : https://download.gimp.org/pub/gimp/v2.10/

Testé sur Win 10 pro 64 bits et Win 7 32 bits.

Quelques plugins pour cette version sont disponibles aux pages :
https://samjcreations.blogspot.com/2018/05/filtres-anciens-pour-gimp-210-windows.html
https://samjcreations.blogspot.com/2018/05/filtres-anciens-pour-gimp-210-64-bits.html
https://samjcreations.blogspot.com/2018/05/filtres-anciens-pour-gimp-210-64-bits_24.html
https://samjcreations.blogspot.com/2018/05/filtres-anciens-pour-gimp-210-64-bits_25.html
https://samjcreations.blogspot.com/2018/05/filtres-anciens-pour-gimp-210-64-bits_27.html


*****
*****


8 commentaires:

  1. It seems that filters interfacing (calling) GMIC do not work properly, GMIC replies with an error

    Traceback (most recent call last):
    File "C:\Users\Diego\Desktop\Gimp-2.10.4_Portable-32bit-64bit-V4\lib\gimp\2.0\python\gimpfu.py", line 740, in response
    dialog.res = run_script(params)
    File "C:\Users\Diego\Desktop\Gimp-2.10.4_Portable-32bit-64bit-V4\lib\gimp\2.0\python\gimpfu.py", line 361, in run_script
    return apply(function, params)
    File "C:\Users\Diego\Desktop\GimpEval-2.10-Win_MyAddons\python Diego 210 additional\DIEGO_TEST_Mosaic_Stained_Glass_QT210_test.py", line 221, in Mosaic_Stained_Glass_QT210_Test
    +"0")
    RuntimeError: Procedure 'plug-in-gmic-qt' returned no return values

    Could you make accessible again the previous release, which seems to have disappeared?
    COULD BE THAT THE PROBLEM IS IN GMIC, not in your package…

    Thanks a lot, Sylvie et Michel

    RépondreEffacer
    Réponses
    1. Bonjour,

      Here are the links of the two old Gimp archives :

      gimp.org version - Gimp 2.10.4
      http://www.aljacom.com/~gimp/Gimp-2.10.4_Portable-32bit-64bit-V3.7z

      MSYS2 version with Python of MSYS2 - Gimp 2.10.5 compiled July 7
      http://www.aljacom.com/~gimp/GimpEval-2.10-Win.7z


      Python

      The Python version of MSYS2 has been updated since this compilation. I do not know if it's important for Gimp.

      On the next GimpEval 2.10 I'll maybe put this version https://www.python.org/downloads/release/python-2715/


      G'MIC

      There is a newer version that is compatible https://gmic.eu/files/prerelease/gmic_gimp2.10_qt_win64.zip

      Tell me if you think it's G'MIC.

      :o)



      Effacer

  2. Thanks. Downloaded/installed the provided v3, still the same error.
    But I noticed it has embedded the same GMIC-QT version 2.3.4 of the last package.
    Another older version of your package I have (but to not remember which version is, if 2.10.4-V2 or before) runs properly having GMIC-QT 2.2.4.
    Hence I believe it's a matter of the GMIC-QT version.
    Could you pack your last V4 with GMIC-QT 2.2.4?
    Thanks a lot.

    RépondreEffacer
  3. BTW, on the official site of GMIC the last stable version mentioned is 2.3.3; maybe the 2.3.4 has some errors still in, IDK

    RépondreEffacer
  4. Bonjour,

    All versions of G'MIC are available on this link :
    https://gmic.eu/files/windows/

    :o)

    RépondreEffacer
  5. Thanks for the info.
    In that link it seems the most recent gmic-gimp-qt version is 2.2.2.
    Nonetheless I downloaded that one and replaced the .exe module 2.3.4-pre packaged in your pack(s) and now the program calling gmic. functions runs properly
    This confirm that 2.3.4-pre (which you embedded in your last 3 packs) is not good. I think you have to consider replacing it with an older version.
    Hope you have the possibility to double-check.

    RépondreEffacer
  6. I made another test, to help you.
    From gmic.eu I downloaded the last stable version of gmic-gimp-qt, i.e. 2.3.3, taken the .exe and put it in place of the existing 2.3.4pre and the program(s) calling Gmic work perfectly.
    Thus, it seems the problem is only with 2.3.4pre.
    IMO it's better if you avoid to embed it in your packages.

    RépondreEffacer
    Réponses
    1. Bonjour,

      Thank you for the tests and the information.
      The G'MIC version of this archive is quite old.
      I will replace G'MIC with a new version of GimpEval.

      :o)

      Effacer